Impacted RightSignature Functionality
Incident Report for Citrix RightSignature Status Page
Resolved
This incident has been resolved.
Posted Aug 07, 2018 - 10:05 EDT
Monitoring
We believe the application is now functioning properly however, we are continuing to monitor performance and will provide an additional update once resolved.
Posted Aug 07, 2018 - 09:47 EDT
Investigating
As we have continued monitoring - we have become aware of continued issues impacting uploads and the use of templates. We continue to be engaged and work to ensure these issues are fully resolved. We will provide further updates no later than 10:30am ET.
Posted Aug 07, 2018 - 09:36 EDT
Monitoring
We are aware of issues impacting uploads and the use of templates on rightsignature.com due to an extension of regularly scheduled maintenance. Our development team currently investigating and we will provide an update within the next hour.
Posted Aug 07, 2018 - 09:25 EDT
This incident affected: RightSignature System Status.