Citrix RightSignature customers experiencing latency issues
Incident Report for Citrix RightSignature Status Page
Resolved
At this time, we believe that the latency issues affecting Citrix RightSignature service have been resolved. We will continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Oct 15, 2020 - 15:20 EDT
Update
Engineering team is still working on steps to mitigate the issue and will provide additional updates on this site once available
Posted Oct 15, 2020 - 14:14 EDT
Update
Engineering team is still working on steps to mitigate the issue and will provide additional updates on this site once available
Posted Oct 15, 2020 - 12:45 EDT
Investigating
Citrix Teams are investigating a latency issue impacting customers of Citrix RightSignature impacting all regions.

Citrix engineering is diligently working on resolution, and will provide additional updates on this site once available.
Posted Oct 15, 2020 - 12:04 EDT
This incident affected: RightSignature System Status.