Citrix RightSignature service is experiencing issues in the US region...
Incident Report for Citrix RightSignature Status Page
Resolved
Current Status:

At this time, we believe that the issues affecting the Citrix RightSignature service have been fully resolved. We will continue to monitor closely.



Next Steps:

If any further issues are seen, please contact Citrix Technical Support.
Posted Feb 16, 2022 - 12:35 EST
Update
The team continues to investigate this issue,
Posted Feb 16, 2022 - 12:09 EST
Investigating
Impact: Citrix RightSignature service is experiencing issues in the US region leading to admins and users experiencing latency.



Current Status: Citrix Engineering is currently investigating the issue.



Next Steps: A further update will be provided within 60 minutes.
Posted Feb 16, 2022 - 11:48 EST
This incident affected: RightSignature System Status.