Citrix RightSignature (powered by ShareFile) customers may be experiencing issues…
Incident Report for RightSignature Status Page
Resolved
The outage affecting Citrix RightSignature has been fully resolved.

If further issues persist, please contact Technical Support.
Posted Oct 14, 2022 - 17:45 EDT
Investigating
Impact:
Citrix RightSignature customers may be experiencing issues accessing the login page.

Current Status:
Citrix Engineering is actively investigating the issue and working towards mitigation.

Next Steps:
We will share an update within the next hour.
Posted Oct 14, 2022 - 16:26 EDT
This incident affected: RightSignature System Status.