RightSignature Phone System Temporarily Unavailable
Incident Report for Citrix RightSignature Status Page
Resolved
We have identified the issue that was causing the RightSignature phone system to be unavailable. We apologize for any inconveniences this may have caused.
Posted Nov 30, 2017 - 14:13 EST
Investigating
We are investigating an issue that is causing our phone system to be temporarily unavailable. This issue is being worked on as a high priority. We apologize for this inconvenience.
Posted Nov 30, 2017 - 12:07 EST