Citrix RightSignature customers experiencing issues with Payment Provider Integration
Incident Report for Citrix RightSignature Status Page
Resolved
At this moment we believe the issues impacting RightSignature service have been resolved. We will continue to monitor closely.

To report any observed issues with the service, please contact Citrix Support.
Posted Jun 25, 2021 - 14:29 EDT
Identified
Current Status: Citrix Engineering team has identified the issue and actively collaborating with an upstream third-party provider to restore normal service functionality to our customers. At present there are no identifiable work arounds or ETA for a fix.

Next Steps: A further update will be provided as soon as available.
Posted Jun 24, 2021 - 13:15 EDT
Investigating
Impact: Citrix RightSignature customers are currently experiencing issues with Payment Provider Integration feature of the service.

Current Status: Citrix Engineering teams are engaged and investigating the issue. At present there are no identifiable work arounds or ETA for a fix.

Next Steps: A further update will be provided within the next 60 minutes (no later than 16:45 UTC).
Posted Jun 24, 2021 - 11:42 EDT
This incident affected: RightSignature System Status.