Right Signature customers in the US experiencing issues
Incident Report for Citrix RightSignature Status Page
Resolved
At this time, we believe that the issues affecting the RightSignature service have been fully resolved. We will continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Sep 15, 2020 - 17:59 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 15, 2020 - 17:59 EDT
Monitoring
At this time, we believe that the issues affecting the RightSignature service have been fully resolved. We will continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Sep 15, 2020 - 17:54 EDT
Update
RightSignature is currently experiencing issues in the US region that would impact both end-users and admins.

Impact:
Users accessing RightSignature are seeing an error saying "Document Limit Reached" and are unable to use the service
(https://support.citrix.com/article/CTX237643)

Citrix Engineering is currently deploying a fix for this issue which is expected to be completed within the next 15 minutes. For some customers, refreshing the page or logging out and back in is a possible workaround. A further update will be provided within 30 minutes (no later than 5:50PM EDT).
Posted Sep 15, 2020 - 17:20 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 15, 2020 - 17:19 EDT
Update
RightSignature is currently experiencing issues in the US region that would impact both end-users and admins.

Impact:
Users accessing RightSignature are seeing an error saying "Document Limit Reached" and are unable to use the service
(https://support.citrix.com/article/CTX237643)

We have identified the issue and are currently testing the fix for this error. For some customers, refreshing the page or logging out and back in is a possible workaround. A further update will be provided within 30 minutes (no later than 5:25PM EDT).
Posted Sep 15, 2020 - 16:55 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 15, 2020 - 16:50 EDT
Update
RightSignature is currently experiencing issues in the US region that would impact both end-users and admins.

Impact:
Users accessing RightSignature are seeing an error saying "Document Limit Reached" and are unable to use the service
(https://support.citrix.com/article/CTX237643)

We have identified the issue and are still working on a code fix for this error. For some customers, refreshing the page or logging out and back in is a possible workaround. A further update will be provided within 30 minutes (no later than 4:55PM EDT).
Posted Sep 15, 2020 - 16:22 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 15, 2020 - 16:21 EDT
Identified
RightSignature is currently experiencing issues in the US region that would impact both end-users and admins.

Impact:
Users accessing RightSignature are seeing an error saying "Document Limit Reached" and are unable to use the service
(https://support.citrix.com/article/CTX237643)

We have identified the issue and are currently testing out a code fix for this error. For some customers, refreshing the page or logging out and back in is a possible workaround. A further update will be provided within 30 minutes (no later than 4:25PM EDT).
Posted Sep 15, 2020 - 15:55 EDT
This incident affected: RightSignature System Status.