Site Issue
Incident Report for Citrix RightSignature Status Page
Resolved
This issue has been resolved. If you continue experiencing issues, please contact us at 800.921.4250.
Posted Sep 26, 2017 - 18:20 EDT
Investigating
We are currently experiencing issues with the RightSignature landing page. Users are still able to login and use the site by accessing https://rightsignature.com/login

We are working to resolve this issue as quickly as possible. Thank you for your patience.
Posted Sep 26, 2017 - 17:52 EDT