Delay in Dashboard updates
Incident Report for Citrix RightSignature Status Page
Resolved
The previous issue with accessibility on the Dashboard and viewing Templates and Online Forms have been restored. Please contact our customer support team if you are still experiencing any difficulties.
Posted Nov 06, 2017 - 10:02 EST
Monitoring
The issue has been identified and updates to your Dashboard, Online Forms and Templates should be restored at this time. We are currently monitoring the situation to ensure accessibility continues.
Posted Nov 06, 2017 - 09:05 EST
Investigating
We are receiving reports of delayed updates to the Dashboard, Templates and Online Forms in the Classic Version. Our engineering team is currently investigating this delay. We appreciate your patience as we work to fully resolve this issue.
Posted Nov 06, 2017 - 08:30 EST