RightSignature4 not accessible
Incident Report for Citrix RightSignature Status Page
Resolved
The log in issue experienced by customers using .com domain has been resolved. We have identified and resolved the cause of this issue and are working to prevent such future occurrences.
Thank you for your patience and we regret the inconvenience caused.
Posted Sep 25, 2019 - 05:20 EDT
Investigating
We have been made aware of RightSignature4 not being accessible in US region(all .com domains)
We are working to research and resolve the issue and will provide updates as soon as additional information is available.
Posted Sep 25, 2019 - 03:28 EDT
This incident affected: RightSignature System Status.