Documents not appearing in dashboard
Incident Report for Citrix RightSignature Status Page
Resolved
This incident has been resolved.
Posted Jun 02, 2018 - 09:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2018 - 15:33 EDT
Investigating
We are investigating the cause of documents not appearing in the dashboard. This has been identified to only be impacting documents created/signed in the last 24 hours. Our Operations team will perform maintenance after hours today, 6/1/18, and expect the documents to be available again 6/2/18. We apologize for any inconveniences this causes our customers.
Posted Jun 01, 2018 - 11:57 EDT