Citrix RightSignature customers experiencing latency issues.
Incident Report for Citrix RightSignature Status Page
Resolved
At this time, we believe that the latency issues affecting Citrix RightSignature service have been resolved. We will continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Oct 14, 2020 - 17:38 EDT
Update
Initial mitigation steps have improved some of the latency observed by our customers. Citrix engineering is diligently working on final resolution and new updates will be provided on this site once available.
Posted Oct 14, 2020 - 17:22 EDT
Investigating
Citrix Teams are investigating a latency issue impacting customers of Citrix RightSignature impacting all regions.

Citrix engineering is diligently working on resolution, and will provide additional updates on this site once available.
Posted Oct 14, 2020 - 16:28 EDT
This incident affected: RightSignature System Status.