Citrix Right Signature services may be experiencing issues - Investigating
Incident Report for Citrix RightSignature Status Page
Resolved
Impact: Citrix Content Collaboration(Right Signature) service was experiencing latency issues affecting all customers in the US region. 
 
Current Status: At this time, we believe that the issue affecting the Citrix Content Collaboration(Right Signature) service has been fully resolved. We will continue to monitor closely. 
 
Next Steps: If any further issues are seen, please contact Citrix Technical Support.
Posted Sep 15, 2021 - 16:32 EDT
Update
We are continuing to investigate this issue.
Posted Sep 15, 2021 - 16:19 EDT
Investigating
ADVISORY/INVESTIGATING



Current Status:

Citrix Right Signature service is experiencing latency issues affecting all customers in the US region. End-users impacted may be experiencing issues logging in to the service.

Citrix Engineering continues to investigate the issue.



Next Steps:

A further update will be provided within 60 minutes, no later than 20:00 UTC.
Posted Sep 15, 2021 - 15:11 EDT
This incident affected: RightSignature System Status.