Citrix Content Collaboration end users & admins experiencing latency when accessing their sharefile.com login page
Incident Report for Citrix RightSignature Status Page
Resolved
The issue impacting customers of Citrix RightSignature has been resolved. Citrix Engineering will continue to monitor closely. If any further issues are experienced, please contact Citrix Technical Support.
Posted Jun 01, 2020 - 15:16 EDT
Investigating
Citrix Content Collaboration is currently experiencing an issue for users with their control plane in the US. End-users and admins are experiencing latency when loading their sharefile.com login page. Customers who have Right Signature are experiencing issues logging in altogether. We are currently investigating this issue, at present there is no identifiable work-around available nor ETA for fix. A further update will be provided by 7:10 PM UTC.
Posted Jun 01, 2020 - 14:23 EDT
This incident affected: RightSignature System Status.