RightSignature Maintenance
Incident Report for Citrix RightSignature Status Page
Resolved
Today's RightSignature maintenance is now complete and services are back to normal.

We apologize for any inconvenience caused by these issues. Please be sure to contact support if you have any additional questions or concerns - https://rightsignature.com/contact-us
Posted Dec 18, 2017 - 16:25 EST
Identified
RightSignature is currently undergoing emergency maintenance. We are rapidly working to resolve the issue and will post updates here as we receive them.

During this time, you may experience issues utilizing templates or viewing your dashboard. We apologize for any inconvenience caused.
Posted Dec 18, 2017 - 15:59 EST