RightSignature - Completed Documents Failing to Download
Incident Report for Citrix RightSignature Status Page
Resolved
At this point, the issue has been resolved. If any other issues are seen, please contact Citrix Technical Support at https://support.citrix.com/cscase#/.
Posted Mar 05, 2019 - 15:52 EST
Update
In order to make the appropriate changes to resolve the download issues, we have entered into an unscheduled Maintenance mode for our RightSignature 3 application to expedite resolution. We are treating this issue with urgency and will bring the application back online as soon as possible. We will provide additional updates as soon as possible.
Posted Mar 05, 2019 - 12:57 EST
Investigating
We have begun receiving reports from customers that completed documents in RightSignature are failing to download properly.
Our engineering team is engaged and is working to research and resolve the issue. We will provide new updates as soon as we have relevant information.
Posted Mar 05, 2019 - 12:03 EST
This incident affected: RightSignature System Status.