RightSignature Customers Experiencing API Failures

Incident Report for RightSignature Status Page

Resolved

Issue is not affecting RightSignature API customers
Posted May 22, 2023 - 15:38 EDT

Investigating

RightSignature customers may be experiencing issues using the API. We are investigating this issue and we will provide updates here as soon as possible.
Posted May 22, 2023 - 15:11 EDT
This incident affected: RightSignature System Status.