Delay in Dashboard updates
Incident Report for Citrix RightSignature Status Page
Resolved
The previous issue with accessibility on the Dashboard to newly sent documents and viewing Templates and Online Forms have been resolved. Please contact our customer support team if you are still experiencing any difficulties.
Posted Sep 13, 2017 - 14:27 EDT
Identified
The issue has been identified and we are working on restoring updates to the Dashboard, Templates and Online Forms. We appreciate your patience as we work to fully resolve this issue.
Posted Sep 13, 2017 - 13:14 EDT
Investigating
We are receiving reports of delayed updates to the Dashboard, Templates and Online Forms in the Classic Version. Our engineering team is currently investigating this delay. We appreciate your patience as we work to fully resolve this issue.
Posted Sep 13, 2017 - 11:41 EDT