Impacted RightSignature Functionality
Incident Report for Citrix RightSignature Status Page
Resolved
This incident has been resolved and the Import Overlay feature is available for use again.
Posted Oct 01, 2018 - 16:47 EDT
Investigating
We are aware of issues impacting the use of the Import Overlay feature on rightsignature.com. Our development team is currently investigating and we will continue to provide additional updates here.
Posted Oct 01, 2018 - 15:05 EDT
This incident affected: RightSignature System Status.