Citrix RightSignature customers may not be receiving email notifications...
Incident Report for RightSignature Status Page
Resolved
The issue affecting Citrix RightSignature has been fully resolved.

If further issues continue, please contact Technical Support.
Posted Oct 25, 2022 - 17:41 EDT
Identified
Citrix RightSignature customers may not receive email notifications as they have been incorrectly blocked as spam by Yahoo and Yahoo domain affiliates (including yahoo.com, att.net, verizon.net, ymail.com, sbcglobal.net, and others.)

Citrix Engineering is actively working with Yahoo to get this resolved.
Posted Oct 24, 2022 - 10:19 EDT
This incident affected: RightSignature System Status.