Citrix RightSignature customers may be experiencing some issues...
Incident Report for Citrix RightSignature Status Page
Resolved
Current Status:

At this time, we believe that the issues affecting the Citrix RightSignature service have been fully resolved. We will continue to monitor closely.


Next Steps:

This is the final update. If any further issues are seen, please contact Citrix Technical Support.
Posted Dec 31, 2021 - 11:36 EST
Identified
Impact:
Citrix RightSignature service is currently experiencing issues in the US and EU regions. Customers may see an error message stating "Your preview period with Newest version of RightSignature has ended." This would prevent usage of Citrix RightSignature.

Current Status:
Citrix Engineering teams are engaged and investigating the issue. Preliminary evidence points an end of year expiration issue.

Next Steps:
Another update will be provided within the next 60 minutes.
Posted Dec 31, 2021 - 10:56 EST
This incident affected: RightSignature System Status.