RightSignature users are intermittently experiencing performance issues with RightSignature Webapp and Signatures within ShareFile

Incident Report for RightSignature Status Page

Resolved

We have completed steps to restore stability to the customer experience with RightSignature Web App. No further impact has been observed and we are considering this issue to be resolved. If you are still experiencing any issues, please reach out to support.
Posted Feb 07, 2025 - 17:02 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2025 - 16:49 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 07, 2025 - 16:27 EST

Investigating

We are investigating this issue and we will provide updates here as soon as possible.
Posted Feb 07, 2025 - 15:55 EST
This incident affected: RightSignature System Status.