Uploads to RightSignature Failing
Incident Report for Citrix RightSignature Status Page
Resolved
At this point, our processing queues have returned to normal and document uploads should be working normally.
If any other issues are seen, please contact Citrix Technical Support.
Posted Mar 05, 2019 - 08:59 EST
Monitoring
Our development team has made the appropriate changes that we believe have started processing files again. Our queue is working through previously uploaded files in the time they were received. We will continue monitoring until we have verified that the service is fully resolved. We will update accordingly once we have this validation.
Posted Mar 05, 2019 - 08:54 EST
Identified
We have received several reports, and confirmed by our development team, that uploads of documents to RightSignature are failing. Thus, processing files for signatures are blocked. Our team is aware and working through the problem. We will provide an update as soon as we have additional information available.
Posted Mar 05, 2019 - 08:42 EST
This incident affected: RightSignature System Status.