Citrix RightSignature experiencing latency issues
Incident Report for Citrix RightSignature Status Page
Resolved
The issues affecting Citrix RightSignature customers have now been resolved.

Citrix Engineering identified the issue was caused by an ongoing upstream cloud provider maintenance that impacted dependent services, including RightSignature.

Citrix Engineering is closely monitoring the situation.
Posted Nov 12, 2020 - 19:16 EST
Identified
Citrix Engineering identified the issue was caused by an ongoing upstream cloud provider maintenance that impacted dependent services, including RightSignature.

Customers may be experiencing latency issues during time.

Citrix engineering is closely monitoring the situation. Another update will be provided within the next 60 minutes or sooner.
Posted Nov 12, 2020 - 17:12 EST
Investigating
Citrix Engineering teams are investigating a latency issue impacting customers of Citrix RightSignature in the US region.


Citrix engineering is diligently working on resolution. Another update will be provided within the next 60 minutes.
Posted Nov 12, 2020 - 17:00 EST