Latency loading RightSignature dashboard
Incident Report for Citrix RightSignature Status Page
Resolved
We have identified and resolved the issue that was causing latency loading RightSignature dashboards, templates, and download forms. We apologize for any inconveniences this caused.
Posted Apr 25, 2018 - 11:40 EDT
Investigating
We're currently investigating issues regarding loading dashboards, templates, and online forms. We apologize for any inconveniences this may cause our customers. We will continue to provide updates as we know more.
Posted Apr 25, 2018 - 10:46 EDT